As it turns out the way I've historically configured EIGRP is what Cisco now calls EIGRP Autonomous System Configuration. This is the EIGRP that most of us all know and love (?) that starts with the traditional:
router eigrp 1
No more! Down with the autonomous system number in the router command! For this day forward let us NAME our EIGRP config blocks like civilized people!
router eigrp MY_EIGRP
Naturally "MY_EIGRP" can be any bit of free form text that you fancy. IOS help shows it like so:
R1(config)#router eigrp ?One of the changes in how the Named configuration works versus the Autonomous System configuration is that once you enter the 'router eigrp name' command the router DOES NOT start up an EIGRP instance. That doesn't happen until you specify an address-family and autonomous system number. As near as I can tell from the docs is that older syntax had you create the address-family and then within config-router-af mode you specified the autonomous system number. However the newer way is to do both in a single command from router config mode.
<1-65535> Autonomous System
WORD EIGRP Virtual-Instance Name
address-family ipv4 unicast vrf CustA-1 autonomous-system 1You don't have to use this with a VRF, and there's also ipv6 and multicast options in there too. I'll let you explore it at your leisure.
Now that you have an EIGRP process running that's all ready to be configured we can look at how to actually configure it. For the most part our standard set of tools remain unchanged in their usage, but what has changed is where you use these tools.
Named EIGRP has 3 modes that the bulk of the configuration is done under. These are:
- address-family configuration mode - (config-router-af)#
- address-family interface configuration mode - (config-router-af-interface)#
- address-family topology configuration mode - (config-router-af-topology)#
R1(config-router-af)#?Address-family configuration mode is something new. This mode takes all the interface specific commands that you would have previously configured on an actual interface (logical or physical) and moves them into the EIGRP config. EIGRP authentication, split-horizon, and summary-address configuration are some of the options that are now configured here instead of in interface configuration mode.
Address Family configuration commands:
af-interface Enter Address Family interface configuration
default Set a command to its defaults
eigrp EIGRP Address Family specific commands
exit-address-family Exit Address Family configuration mode
help Description of the interactive help system
maximum-prefix Maximum number of prefixes acceptable in aggregate
metric Modify metrics and parameters for advertisement
neighbor Specify an IPv4 neighbor router
network Enable routing on an IP network
no Negate a command or set its defaults
shutdown Shutdown address family
timers Adjust peering based timers
topology Topology configuration mode
R1(config-router-af-interface)#?Address-family topology configuration mode allows you to configure options that relate directly to the EIGRP topology table and its contents. It is in af-topology config mode that you configure redistribution, distribute-lists, and EIGRP variance.
Address Family Interfaces configuration commands:
authentication authentication subcommands
bandwidth-percent Set percentage of bandwidth percentage limit
bfd Enable Bidirectional Forwarding Detection
dampening-change Percent interface metric must change to cause update
dampening-interval Time in seconds to check interface metrics
default Set a command to its defaults
exit-af-interface Exit from Address Family Interface configuration
hello-interval Configures hello interval
hold-time Configures hold time
next-hop-self Configures EIGRP next-hop-self
no Negate a command or set its defaults
passive-interface Suppress address updates on an interface
shutdown Disable Address-Family on interface
split-horizon Perform split horizon
summary-address Perform address summarization
R1(config-router-af-topology)#?And that's about it really. Everything you've already learned about EIGRP still applies, you just use different config modes to set everything up. As of yet I haven't figured out how to redistribute one EIGRP address-family into another EIGRP address-family, so if you know that leave me a comment.
Address Family Topology configuration commands:
auto-summary Enable automatic network number summarization
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter entries in eigrp updates
eigrp EIGRP specific commands
exit-af-topology Exit from Address Family Topology configuration
maximum-paths Forward packets over multiple paths
metric Modify metrics and parameters for advertisement
no Negate a command or set its defaults
offset-list Add or subtract offset from EIGRP metrics
redistribute Redistribute IPv4 routes from another routing proto
summary-metric Specify summary to apply metric/filtering
timers Adjust topology specific timers
traffic-share How to compute traffic share over alternate paths
variance Control load balancing variance
And just for fun, here's the config from my CE that is really 4 CEs I spoke about at the beginning. I added some superfluous config into VRF CustA-1 just to show some of the possibilities. The other 3 are untouched.
router eigrp MPLSIf you're interested in reading further you can find all the EIGRP named configuration details on the DocCD here:
!
address-family ipv4 unicast vrf CustA-1 autonomous-system 1
!
af-interface Loopback11
authentication mode md5
authentication key-chain EIGRP_KEY
exit-af-interface
!
topology base
no auto-summary
redistribute connected
exit-af-topology
network 10.1.0.5 0.0.0.0
network 10.1.1.5 0.0.0.0
eigrp stub connected
exit-address-family
!
address-family ipv4 unicast vrf CustB-1 autonomous-system 1
!
topology base
no auto-summary
exit-af-topology
network 10.1.0.5 0.0.0.0
network 10.1.1.5 0.0.0.0
exit-address-family
!
address-family ipv4 unicast vrf CustB-2 autonomous-system 1
!
topology base
no auto-summary
exit-af-topology
network 10.2.0.5 0.0.0.0
network 10.2.2.5 0.0.0.0
exit-address-family
!
address-family ipv4 unicast vrf CustA-2 autonomous-system 1
!
topology base
no auto-summary
exit-af-topology
network 10.2.0.5 0.0.0.0
network 10.2.2.5 0.0.0.0
exit-address-family
!
http://www.cisco.com/en/US/docs/ios/iproute_eigrp/configuration/guide/ire_cfg_eigrp_ps6350_TSD_Products_Configuration_Guide_Chapter.html
Interesting, as it seems OSPF is moving the other way. i.e. moving more commands under interfaces and less under the global IGP config.
ReplyDeleteTrue. The OSPFv3 moves a lot of the config onto the interfaces. What I haven't got to yet is how this config relates to EIGRPv6. If you can create IPv6 address families within an EIGRP named config then why do you need to use 'ipv6 router eigrp' ?
ReplyDeleteCorrect.. the point of the new CLI is to create a common config across all the protocols (v4/v6) and families (address/service). For v6, you would do:
Deleterouter eigrp MY_NMAE
!
address-family ipv4 autonomous-system 1
.
.
.
address-family ipv6 autonomous-system 1
.
.
.
In regards to the redistribute between VRFs in EIGRP the Configuration Guide(at least for 12.4) says it cannot be done...
ReplyDeleteWhat do you need to enable before you can use named configuration, is it solemly after enabling MPLS, or could be used on my pure flat eigrp implementation?
ReplyDeleteLooks very interesting and want to run it in a test bed.
Thanks in advace
EIGRP named mode is completely independant from MPLS, it is simply a new style of syntax for enabling and configuring EIGRP.
DeleteAlso, remember in this particular example, the EIGRP named mode configuration is being performed on the CE router which is not MPLS aware anyway (only the PE router is)